Skifta mellan fönster i appl med CMD>/< slutat fungera (?)

Tråden skapades och har fått 17 svar. Det senaste inlägget skrevs .
1

Brukar skifta mellan öppna fönster i applikationer på min MBP med tangentkommandot "CMD>" eller "CMD<" (dvs äpplet och mindreän eller merän-tecknen)

Av ngn anledning fungerar detta kortkommando inte på min Mac mini. Har apples eget trådbundna tbord. Undersökt kortkommandofliken i Preferences men hittar inget där...

Ngn som har tips?!

Startat om datorn? Startat om i säkert läge?

Version av MacOS?

Testat starta om, även i felsäkert läge. Skärmen "blinkar till" när man trycker CMD< men inget fönsterskifte.
Kör senaste Sierra på båda maskinerna (10.12.6)

Kanske råkat byta tangentbordslayout, så att > och < inte sitter där de ska?

Ursprungligen av Jesper Ohlsson:

Kanske råkat byta tangentbordslayout, så att > och < inte sitter där de ska?

Bra tips! Har Svensk Pro, testade köra "Svensk" men nixum. Och kan ju också skriva < och >.
Har ett BT tangentbord också, det fungerar inte heller med CMD<

Nu testat båda tangentborden i min MPB 15" (2015 års modell)
Kortkommandot fungerar med BT_tangentbordet men inte med trådade tbord.

Skumt. Gissar det är ngt systemtrassel med min Mini men att trådade tbordet fungerar inpluggat i min MBP talar väl för att tbordet inte fungerar riktigt 100?

Öppna tangentbordslayout och kolla rätt tangent trycks.

Enl Systeminställn så verkar det som om tangentbordet ej identifieras som Apple_tbord (får samma medd på mitt trådade som BT_tangentbordet) Se dump nedan

Kan ngt i "Keyboard.prefPane" blivit korrupt - dvs törs man typ radera denna fil, starta om och hålla tummarna

Ursprungligen av Stefan Johansson:

Kan ngt i "Keyboard.prefPane" blivit korrupt - dvs törs man typ radera denna fil, starta om och hålla tummarna

Själva prefpane-filen ska du inte radera. Men det finns ju säkert någon inställningsfil till den som du kan radera. (Filnamn bör vara någonting med keyboard och plist)

Min gissning är att ditt tangentbord identifieras som ett med ANSI-layout (101 knappar) och inte ett ISO (104).
Har själv haft samma problem, lösningen blev Karabiner-Elements (gratis), som erbjuder möjligheten att själv definiera vad som är anslutet.

Brasklapp: jag har länge använd Karabiner-Elements, så det kan mycket väl vara det programmet som är boven i mitt drama.

Ursprungligen av reboot81:

Min gissning är att ditt tangentbord identifieras som ett med ANSI-layout (101 knappar) och inte ett ISO (104).
Har själv haft samma problem, lösningen blev Karabiner-Elements (gratis), som erbjuder möjligheten att själv definiera vad som är anslutet.

Det låter som en sannolik förklaring. Laddad ned men förstår inte riktigt hur jag ställa in... Har du ngt tips ?

En intressant obs i Eventviewer, när jag trycker på <>-tangenten rapporteras den som "KeyUp/Down - grave_accent_and_tilde" - det låter ju inte som störreän/mindreän-tkn

UPDATE:
Vad heter<>-knappen på engelska? Verkar som om man kan mappa om den knappen.

@reboot81 - tror jag förstår hur Karabiner fungerar nu men lyckas inte fixa detta ändå - har valt ISO i Preferences/Virtual Keyboard men i Event viewer visar slag på <> att det är grave_accent_tilde och inte non_us_backslash som är "rätt tecken"

Också testat att göra Simple Modification, dvs mappa om "grave_accent..." till "non_us.."

T-bordet "skriver" rätt tecken men CMD</> vill inte funka ändå.

Ursprungligen av Stefan Johansson:

@reboot81 - tror jag förstår hur Karabiner fungerar nu men lyckas inte fixa detta ändå - har valt ISO i Preferences/Virtual Keyboard men i Event viewer visar slag på <> att det är grave_accent_tilde och inte non_us_backslash som är "rätt tecken"

Också testat att göra Simple Modification, dvs mappa om "grave_accent..." till "non_us.."

T-bordet "skriver" rätt tecken men CMD</> vill inte funka ändå.

Är det i alla program CMD</> inte fungerar?

CMD+</> säger "grave_accent_and_tilde". </> knappen ger < resp >.
Knappen till vänster om 1 ger § resp °.
Jag har valt ISO i Karabiner, tangentbordet är ett Svenskt stort trådat.

Ursprungligen av reboot81:

Är det i alla program CMD</> inte fungerar?

CMD+</> säger "grave_accent_and_tilde". </> knappen ger < resp >.
Knappen till vänster om 1 ger § resp °.
Jag har valt ISO i Karabiner, tangentbordet är ett Svenskt stort trådat.

Ja, CMD</> fungerar inte i ngt program. (dock ett undantag och det är Terminal där det fungerar)
Jag får samma respons i Karabine Viewer och har valt ISO i Karabiner Elements. Kör också trådat tbord.
Jag ger upp Förhoppningsvis blir det rätt iom 10.13 som väl kommer i höst

Funkar CMD+Shift+</> i andra program?

Ursprungligen av reboot81:

Funkar CMD+Shift+</> i andra program?

Samma med CMD+shift +<>

Det beror sannolikt på att programmet du använder har knutit det kortkommandot till något annat. Så var det med Pages vid nåt tillfälle vet jag (är kanske så fortfarande?), så jag gick in i Systeminställningar > Tangentbord > Kortkommandon och gav andra kortkommandon till det som nu var i vägen.

@carlsson - that did the trick! Jag återställde allt i den inställningen och nu fungerar det igen. Oerhört tacksam för hjälpen!!
@reboot81 - stort även till dig f dina tips! Lärde mig nya saker!

1
Bevaka tråden