Problem med hemsidor som ligger hos one.com

Tråden skapades och har fått 18 svar. Det senaste inlägget skrevs .
1
  • Medlem
  • Skattungbyn
  • 2018-11-12 12:42

Det gäller One.com
Jag har ett flertal sidor liggande på deras servrar. Nu har de installerat något nytt program som gör att det inte längre går att komma in på sidorna. De hemsidor som i första han berörs är fattiga.se och levabilligt.se
Det som gör mig förbannad är att detta sker under pågående avtalsperiod och att One.com INTE vill hjälpa till.

Ursprungligen av torin:

...de installerat något nytt program som gör att det inte längre går att komma in på sidorna...

Vilken webbläsare och vilket operativsystem använder du när du försöker komma in?

Och beskriv gärna lite närmare än bara "går inte". Beskriv vad du gör, och vad som händer då.

Senast redigerat 2018-11-12 12:58
  • Medlem
  • Skattungbyn
  • 2018-11-12 13:01
Ursprungligen av Jesper Ohlsson:

Vilken webbläsare och vilket operativsystem använder du när du försöker komma in?

Och beskriv gärna lite närmare än bara "går inte". Beskriv vad du gör, och vad som händer då.

Safari, men det är inte läsaren som är problemet. Det är att One.com ändrar sina programvaror. Än så länge är det bara fattiga.se och levabilligt.se som är drabbade. Gå in på sidorna så ser du själv!
Det som retar mix extra är att jag ju betalat för nästan ett år till och så gör de så att sidorna inte fungerar längre.

  • Medlem
  • Göteborg
  • 2018-11-12 13:11
Ursprungligen av torin:

Safari, men det är inte läsaren som är problemet. Det är att One.com ändrar sina programvaror. Än så länge är det bara fattiga.se och levabilligt.se som är drabbade. Gå in på sidorna så ser du själv!
Det som retar mix extra är att jag ju betalat för nästan ett år till och så gör de så att sidorna inte fungerar längre.

Antagligen behöver du logga in i hemsidesprogrammet och göra någon inställning.
Hemsideprogrammet (NYTT)

Bara en gissning, har du ställt in vilken sida som är startsida?

Om jag prövar adressen http://fattiga.se/index.html får jag inte ett felmeddelande som om man bara prövar domänen, utan en helt blank sida.

  • Medlem
  • Malmö
  • 2018-11-12 13:37

Jag kan också tycka att det är ganska illa att lösenordet till db:n presenteras i felmeddelandet man får i browsern, connector-strängen ser ut att innehålla detta i klartext.

Du kanske vill byta ut det nu.

  • Inte helt 100
  • Storbritannien
  • 2018-11-12 14:26

"Felet" är nog som sådant att One har uppdaterat sin PHP-version. Mysql_connect finns inte längre: https://secure.php.net/manual/en/function.mys...
Det är dags att uppdatera din kod. 5.5.0 kom för mer än fem år sen (då blev funktionen obsolet) och den togs bort i 7.7.0 som kom 2015 så jag tycker inte man kan klandra One.com för att inte ge sina användare tid att se till att bli uppdaterade på förändringar i språken man programmerat i.
Använder du något förinstallerad produkt från One kan jag tycka att du har rätt att klaga på dem om de inte informerat dig, men jag har lite svårt att se att så kan vara fallet.

Ursprungligen av torin:

...Gå in på sidorna så ser du själv!...

Av frågeställningen fick jag intrycket att problemet rörde din inloggning för att jobba med och administrera sidorna. Därför ställde jag frågan kring webbläsare och operativsystem.

Men nu när vi vet lite mer, så kan jag bara hålla med föregående talare. Jag är säker på att ONE har informerat om de här uppdateringarna i god tid, så att du skulle hinna uppdatera dina sidor.

  • Medlem
  • Skattungbyn
  • 2018-11-12 16:59
Ursprungligen av Jesper Ohlsson:

Av frågeställningen fick jag intrycket att problemet rörde din inloggning för att jobba med och administrera sidorna. Därför ställde jag frågan kring webbläsare och operativsystem.

Men nu när vi vet lite mer, så kan jag bara hålla med föregående talare. Jag är säker på att ONE har informerat om de här uppdateringarna i god tid, så att du skulle hinna uppdatera dina sidor.

Jag har det senaste halvåret varit svårt sjuk efter operation. Så om One.co sänt några informationer så känner jag inte till det. Vad jag däremot vet är att jag betalt för att ha mina hemsidor hos dem. Tycker att det är rimligt att de betalar tillbaka. så här ser det ut.
Sidorna fattiga.se är betald med 482.50 till 2019.05.31
levabilligt.se är betald med 482.50 till 2019-09-15
Mystiska.se betald med 462.50 till 2018-12-16
mosterbeda.com är betald med kr 468.75 till 2018-11-29

Ursprungligen av torin:

Jag har det senaste halvåret varit svårt sjuk efter operation. Så om One.co sänt några informationer så känner jag inte till det. Vad jag däremot vet är att jag betalt för att ha mina hemsidor hos dem. Tycker att det är rimligt att de betalar tillbaka. så här ser det ut.
Sidorna fattiga.se är betald med 482.50 till 2019.05.31
levabilligt.se är betald med 482.50 till 2019-09-15
Mystiska.se betald med 462.50 till 2018-12-16
mosterbeda.com är betald med kr 468.75 till 2018-11-29

Se punkt 1.5:
https://www.one.com/sv/affaersvillkor

Nu vet du iaf vart du ska börja för att lösa problemet

  • Inte helt 100
  • Storbritannien
  • 2018-11-12 18:13
Ursprungligen av torin:

Jag har det senaste halvåret varit svårt sjuk efter operation. Så om One.co sänt några informationer så känner jag inte till det. Vad jag däremot vet är att jag betalt för att ha mina hemsidor hos dem. Tycker att det är rimligt att de betalar tillbaka. så här ser det ut.
Sidorna fattiga.se är betald med 482.50 till 2019.05.31
levabilligt.se är betald med 482.50 till 2019-09-15
Mystiska.se betald med 462.50 till 2018-12-16
mosterbeda.com är betald med kr 468.75 till 2018-11-29

One har lite information om vad de stödjer för versioner av PHP och hur man byter mellan dem här: https://help.one.com/hc/sv/articles/360000448...
Enligt samma sida (och övriga hjälpsidor) informerar de sina kunder som har gamla versioner av PHP. Kanske har de informerat dig men du har inte noterat det?

Den koden som visas när man går in på dina två sajter du påpekade inte fungerade tidigare använder sig av en funktion i PHP som inte längre stöds. PHP är ett aktivt språk som kräver att man håller sig uppdaterad. I detta fallet är det mer än fem år sedan de sa att denna funktion kommer att tas bort. One kan (och bör) inte stödja allt för gamla versioner då de kan innebära allvarliga säkerhetsbrister.

Är det så att du använt dig av t.ex Wordpress eller Joomla eller en annan CMS? I så fall får du se till att uppdatera den till en nyare version.

  • Medlem
  • Skattungbyn
  • 2018-11-13 10:37
Ursprungligen av suddgummi:

One har lite information om vad de stödjer för versioner av PHP och hur man byter mellan dem här: https://help.one.com/hc/sv/articles/360000448...
Enligt samma sida (och övriga hjälpsidor) informerar de sina kunder som har gamla versioner av PHP. Kanske har de informerat dig men du har inte noterat det?

Den koden som visas när man går in på dina två sajter du påpekade inte fungerade tidigare använder sig av en funktion i PHP som inte längre stöds. PHP är ett aktivt språk som kräver att man håller sig uppdaterad. I detta fallet är det mer än fem år sedan de sa att denna funktion kommer att tas bort. One kan (och bör) inte stödja allt för gamla versioner då de kan innebära allvarliga säkerhetsbrister.

Är det så att du använt dig av t.ex Wordpress eller Joomla eller en annan CMS? I så fall får du se till att uppdatera den till en nyare version.

Tack för bra svar. Jag använde E107 när jag lade upp sajterna. Men det är nu så länge sedan att jag inte minns var jag skall gå in och var jag hittar mina inloggningskoder.

  • Inte helt 100
  • Storbritannien
  • 2018-11-13 12:37
Ursprungligen av torin:

Tack för bra svar. Jag använde E107 när jag lade upp sajterna. Men det är nu så länge sedan att jag inte minns var jag skall gå in och var jag hittar mina inloggningskoder.

Bra att du kom ihåg vad du använde! De har en del instruktioner för hur man uppdaterar från äldre versioner på e107.org i deras FAQ: https://e107.org/faqs . Jag känner inte till det CMS:et själv men det verkar vara under aktiv utveckling så det bör stödja nyare versioner av PHP och MySQL.

Om det är inloggningsuppgifter till One.com som du är ute efter kan säkert deras support hjälpa dig att återställa lösenord. Om det är till databasen så står det tyvärr i klartext när man slår in sökvägen till dina två sajter (du bör byta dem). Gissningsvis har du tidigare använt sig av FTP för att föra över filer? One guidar här: https://help.one.com/hc/sv/sections/115001513...

  • Medlem
  • Skattungbyn
  • 2018-11-13 16:25
Ursprungligen av suddgummi:

Bra att du kom ihåg vad du använde! De har en del instruktioner för hur man uppdaterar från äldre versioner på e107.org i deras FAQ: https://e107.org/faqs . Jag känner inte till det CMS:et själv men det verkar vara under aktiv utveckling så det bör stödja nyare versioner av PHP och MySQL.

Om det är inloggningsuppgifter till One.com som du är ute efter kan säkert deras support hjälpa dig att återställa lösenord. Om det är till databasen så står det tyvärr i klartext när man slår in sökvägen till dina två sajter (du bör byta dem). Gissningsvis har du tidigare använt sig av FTP för att föra över filer? One guidar här: https://help.one.com/hc/sv/sections/115001513...

Länge sedan jag använde något FTPprogram. Hade en gång i tiden Cyberduck. Men vad skall jag nu använda?

  • Inte helt 100
  • Storbritannien
  • 2018-11-13 18:22
Ursprungligen av torin:

Länge sedan jag använde något FTPprogram. Hade en gång i tiden Cyberduck. Men vad skall jag nu använda?

Cyberduck är fortfarande ett jättebra alternativ. Det är det programmet jag själv använder närhelst jag behöver en FTP/SFTP klient på Macen.

  • Redaktör
  • Sollentuna
  • 2018-11-13 18:36

Jag har också en hemsida via One och ja, de har vid några tillfällen mejlat om de här ändringarna gällande PHP-versionerna.

Ledsen att det drabbar dig så här @torin. Hoppas du lyckas uppdatera/lösa allt.

  • Medlem
  • Skattungbyn
  • 2018-11-15 14:08
Ursprungligen av suddgummi:

Cyberduck är fortfarande ett jättebra alternativ. Det är det programmet jag själv använder närhelst jag behöver en FTP/SFTP klient på Macen.

Skulle ladda ner Cyberduck, men blev tveksam eftersom de envisades med att jag skulle ladda ner ett cleenerprogram. https://en.softonic.com/download/cyberduck/ma...
Vågar jag mig på det?

  • Inte helt 100
  • Storbritannien
  • 2018-11-15 15:47
Ursprungligen av torin:

Skulle ladda ner Cyberduck, men blev tveksam eftersom de envisades med att jag skulle ladda ner ett cleenerprogram. https://en.softonic.com/download/cyberduck/ma...
Vågar jag mig på det?

Varför tar du inte och laddar ner direkt från Cyberduck? Det finns en länk i inlägget du citerade. Annars kan du klicka här för att komma direkt till nedladdningssidan: https://cyberduck.io/download/

Jag håller med suddgummi. En tumregel är att alltid ladda ned direkt från tillverkaren.

Om man går via nedladdningssajter (t.ex. Softonic som du länkade till) så försöker de ofta pracka på en något extra.

  • Medlem
  • Skattungbyn
  • 2018-11-15 16:40
Ursprungligen av suddgummi:

Varför tar du inte och laddar ner direkt från Cyberduck? Det finns en länk i inlägget du citerade. Annars kan du klicka här för att komma direkt till nedladdningssidan: https://cyberduck.io/download/

Tack, det funkade bättre.

1
Bevaka tråden